Etcdctl --version showing different version than kubectl describe pod etcd-master -n kube-system

Why it is showing different version ?
Events:
Type Reason Age From Message


Normal Pulled 18m kubelet, master Container image “k8s.gcr.io/etcd:3.3.15-0” already present on machine
Normal Created 18m kubelet, master Created container etcd
Normal Started 18m kubelet, master Started container etcd
master $ etcdctl --version
etcdctl version: 3.3.13
API version: 2strong text

Hello satyam,
etcdctl is the version for etcd service installd, this image “ k8s.gcr.io/etcd:3.3.15-0 ” is installed as a container. you can check the version by: kubectl exec -n kube-system etcd-master -- etcdctl --version

Hello @KodeKloud, I’m experiencing the same issue Satyam was experiencing.
On Mock Exam - 2.
The issue makes the first question not doable, see terminal output.
master etcdctl --version etcdctl version: 3.3.1 API version: 2 master kubectl exec -n kube-system etcd-master – etcdctl version
etcdctl version: 3.4.3
API version: 3.4

I have tried fixing it by using:
master ETCDCTL_API=3 etcdctl version etcdctl version: 3.3.1 API version: 3.3 But this is not adequate. Trying with the ETCDCTL_API=3.4 yields: master ETCDCTL_API=3.4 etcdctl version
unsupported API version 3.4

These are incompatible, snapshot will not work.
Also: the video with solutions is out of date, they are not the same as are asked in the exam.

Hello, @jreb
By default, we use ETCDCTL_API=‘3’ instead of ETCDCTL_API=‘3.4’. You can visit this etcd docs.

Hi @player001
Yes, I’ve tried this, it does not work since as you can see in my earlier post, the api running on the master in the docker container is 3.4, while the etcdctl tool only supports up to 3.3