Error with etcd backing up in Mockexam-2

In Mockexam-2 of CKA, the first question asking about etcd backup fails with error saying can’t open file server.crt. When checked for solution it uses health-check.crt, but in /etc/kubernetes/manifests/etcd.yaml it says the cert file used is server.crt.
Tried and repeated the same operation with different pairs of certs, i.e., server.crt and server.key; health-check.crt and health-check.key; peer.key and peer.crt.
Also, when tried removing the part of endpoint completely and tried it, it was showing an error saying on the lines that - “there’s no save command for snapshot command.”

First part - you need to be in the directory containing the file, or provide absolute path - that is /etc/kubernetes/pki/etcd/serv.crt rather than just serv.crt

Second part - don’t forget to set ETCDCTL_API=3. The snapshot does not work without that. etcd is ugly like that :slight_smile:

Hello dronaj,
Please check the following:

Got the error, it is because of mentioning of endpoints in the command, as soon as I remove endpoints it’s working fine. Thanks for help.