Docker-compose installation is broken

Hello Team,

It seems the docker-compose installation is broken on the app servers. I tried multiple ways by following docker official documentation but it failed because of a python error.

Screenshot 2021-01-24 at 12.32.10 AM

I tried with pip as well and it failed with a different error.

Please help.

@Inderpreet @mmumshad @player001 Please help.

Looks like this could be related:

You can use the python package manager (pip) to install docker-compose.

I tried that as well but was getting the error that I have attached in the last screenshot. It was related to gcc. Also I have applied for the review, you can check the complete commands that I tried. @mihsan

Your errors seem to be a transient issue. Give it another try. I don’t think this will repeat again.

If you again receive the error, post it here without finishing the task (we will see to dissect the problem).

It doesn’t look like it was one off. I received the same error on stapp03 server as well.

@mihsan @mmumshad @Inderpreet
This seems to be a new issue with Centos7 and docker-compose, please check the ongoing discussion here: https://github.com/docker/compose/issues/8048