DevOps Prereq Lab - SSL TSL #9

Sent the following question, still no reply. Can someone pls respond as waiting to continue on.

For : For the following question: Using the mykey SSH key-pair you created in previous question configure password less SSH connection between jump
host and app01 for user thor. (thor user should already be there on both servers).

I did the following:
ssh-copy-id -I ~ssh/ thor@app01

ssh ‘thor@app01’
want to continue - yes
then asks for password?

Have I done the steps above correctly? If not pls provide exact commands
is there a password? if so what???

Hope to hear soon as waiting before can continue. thank you


Hi! Initially it asks for the password. Double check if you are able to login without entering the password second time.

no tried this already. another day wasted in getting an answer

Hello, @fifafd350
You can follow this step. As you knew in the previous question, you created public and private keys under the /home/thor/.ssh/

  1. You can list, respective keys files
ls -l /home/thor/.ssh/
  1. You can copy your public key in to the respective app01 server.
ssh-copy-id -i /home/thor/.ssh/  thor@app01
cd /home/thor

ssh-copy-id -i ~/.ssh/ thor@app01

  1. After this you can easily can do passwordless ssh
ssh thor@app01

If any issue, you are facing let me know.

Hi @player001 @KodeKloud
key sucessfully copied, but verify shh access test is getting failed,
Also please can anyone tell me why we are able to ssh to app01 from jump_host but not vice versa ?

You need to enter the file name to save the key

ie, /home/thor/.ssh/