Creating Chained Builds in Jenkins

I got this validation error.

I closely paid attention not to commit such mistakes and also both the jobs ran perfectly with no errors when changes were pushed. I believe there is some validation problem . Please look into it ASAP as I already invested significant amount of time in this task.

Please find the attached file for your reference:

Thanks @Inderpreet @rahul456 @KodeKloud @player001

This is follow up query to my previous post . Could anybody tell me if this was a valid error or not . @Inderpreet @rahul456 @KodeKloud
Thanks

In my case the task failed with the next error:

I tested it end-to-end before submitting the task and everything was working fine… from commit and pushing the changes to the Gitea repo which triggers the first job on jenkins copying the file to /data, then downstream job is activated which is restarting the httpd service on all app servers.

I made sure the below command works fine to copy the index.html file to the /data folder which is used by the web server to load its content in the storage server…

cp ~/web/index.html /data/index.html

I’m sure it is overwriting the index.html file in the /data folder.

Is the validation testing testing for more files than just index.html???

Thanks in advance.

@Inderpreet, @rahul456, @KodeKloud

My job also get failed but everything executed as per question. KIndly check on it.

Before that index.html file has “Welcome” and i have updated to “Welcome to the xFusionCorp Industries” and it worked. But still failed " :- Seems like Jenkins job is not configured correctly to deploy latest code from Git repository!"

image

image

My two Jenkins jobs failed but all done correctly. Kindly check on it and update

This question has room for improvement.
I keep getting the same validation error message and I’m completing the task end to end as described… I even made sure it works properly by testing myself before clicking submit…
The error message needs to be more specific if the validation script is looking for something specific.
At least, the instructions on this task need to be more specific.

Hi Team,

Kindly someone respond. As per question we did everything and also did testing. It worked fine but still status is failed. Kindly check and update is there any wrong in validation or any mistake in what we did.

I completed this successfully.
We need to copy all the files not just index.html.
Other than that everything seems to be working fine.

In case of further queries , let me know if I can help.
Thanks.

In repo there is only one file index.html so moved that file and they asked to update the index.html file so that job should run automatically and should take the updated content of index. We did that and got the output.

For validation purposes they create their own file and do the process, so in order to complete the task plz see to it that you copy all the files in the repo not only the index.html .
I also got stuck on the same thing, then after searching I got to know this thing.
Thanks, Hope it helps.

@dinesh, @rahul456, @Inderpreet
Thank you. Kindly make my task available.

Could some one help me, how to config the triger?

“configure it in a way that if anyone pushes any new change to the origin repository on master branch then the job should auto build”

@zhaoxin0948

I used poll scm . it will check continuously any change in git repo. If it found any update in Git repo then it will automatically build the job.

  1. Create new job with name “nautilus-app-deployment”.
    Add source code from Git -> Poll sscm -> give schedule - * * * * *

I did the same way,but failed the task.

I copied the index.html file to data dir, not all the files included the git file. Is it the problem?
@nithyaks

So confused.
I got the right result, and use the webhook to trigger the built. Why the task still failed.

Still , try to copy all the files just as a measure and see what happens.

Thank you
I put my task under review now, could you please give me some message there.

@dinesh
I have put my task in review state. Kindly give some comment so that i can try

1 Like

I have same issue, the validation seems to be an issue with few Jenkins tasks, I hope they get into the fix of this issue soon.

Hello all,

Apologies for this issue, since we are not able to record your answers yet for such tasks that you perform from UI so its a bit difficult to review your answers.

Could you please record your answer using some screen recording software such as loom.com ? You can directly share your answer with me in DM and I will review the same to identify the issue with this task.
actually we recommend you all to record your answers for all Jenkins related scenarios this way and in case of failure you can share for review.

Note: avoid sharing your answers directly here on threads because we recommend others to try on their own rather than looking into the answers directly