Configure Local Yum repos

Need some clarification of what went wrong

Hi @Gdawkins

Please note the error Couldn't open file .... for your local repo. Possibly it was not loaded correctly at all.

Delete the repodata directory and run createrepo . in the directory containing the packages and try again.
thanks

Hi, Im able install wget using local repo , but task got failed. may know what went wrong ?

@kgaz

What is your email address ? or KKE username ?

my email id : k.gopi1@outlook.com

@kgaz this is marked as Success for you. I think there was some updates going on in the back end when you submitted this task.

thank you for quick support

‘/packages/downloaded_rpms/perl-Carp-1.26-244.el7.noarch.rpm’ -> ‘/yum_local/perl-Carp-1.26-244.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-constant-1.27-2.el7.noarch.rpm’ -> ‘/yum_local/perl-constant-1.27-2.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-Encode-2.51-7.el7.x86_64.rpm’ -> ‘/yum_local/perl-Encode-2.51-7.el7.x86_64.rpm’
‘/packages/downloaded_rpms/perl-Exporter-5.68-3.el7.noarch.rpm’ -> ‘/yum_local/perl-Exporter-5.68-3.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-File-Path-2.09-2.el7.noarch.rpm’ -> ‘/yum_local/perl-File-Path-2.09-2.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-File-Temp-0.23.01-3.el7.noarch.rpm’ -> ‘/yum_local/perl-File-Temp-0.23.01-3.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-Filter-1.49-3.el7.x86_64.rpm’ -> ‘/yum_local/perl-Filter-1.49-3.el7.x86_64.rpm’
‘/packages/downloaded_rpms/perl-Getopt-Long-2.40-3.el7.noarch.rpm’ -> ‘/yum_local/perl-Getopt-Long-2.40-3.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-HTTP-Tiny-0.033-3.el7.noarch.rpm’ -> ‘/yum_local/perl-HTTP-Tiny-0.033-3.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-libs-5.16.3-294.el7_6.x86_64.rpm’ -> ‘/yum_local/perl-libs-5.16.3-294.el7_6.x86_64.rpm’
‘/packages/downloaded_rpms/perl-macros-5.16.3-294.el7_6.x86_64.rpm’ -> ‘/yum_local/perl-macros-5.16.3-294.el7_6.x86_64.rpm’
‘/packages/downloaded_rpms/perl-parent-0.225-244.el7.noarch.rpm’ -> ‘/yum_local/perl-parent-0.225-244.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-PathTools-3.40-5.el7.x86_64.rpm’ -> ‘/yum_local/perl-PathTools-3.40-5.el7.x86_64.rpm’
‘/packages/downloaded_rpms/perl-Pod-Escapes-1.04-294.el7_6.noarch.rpm’ -> ‘/yum_local/perl-Pod-Escapes-1.04-294.el7_6.noarch.rpm’
‘/packages/downloaded_rpms/perl-podlators-2.5.1-3.el7.noarch.rpm’ -> ‘/yum_local/perl-podlators-2.5.1-3.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-Pod-Perldoc-3.20-4.el7.noarch.rpm’ -> ‘/yum_local/perl-Pod-Perldoc-3.20-4.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-Pod-Simple-3.28-4.el7.noarch.rpm’ -> ‘/yum_local/perl-Pod-Simple-3.28-4.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-Pod-Usage-1.63-3.el7.noarch.rpm’ -> ‘/yum_local/perl-Pod-Usage-1.63-3.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-Scalar-List-Utils-1.27-248.el7.x86_64.rpm’ -> ‘/yum_local/perl-Scalar-List-Utils-1.27-248.el7.x86_64.rpm’
‘/packages/downloaded_rpms/perl-Socket-2.010-4.el7.x86_64.rpm’ -> ‘/yum_local/perl-Socket-2.010-4.el7.x86_64.rpm’
‘/packages/downloaded_rpms/perl-Storable-2.45-3.el7.x86_64.rpm’ -> ‘/yum_local/perl-Storable-2.45-3.el7.x86_64.rpm’
‘/packages/downloaded_rpms/perl-Text-ParseWords-3.29-4.el7.noarch.rpm’ -> ‘/yum_local/perl-Text-ParseWords-3.29-4.el7.noarch.rpm’
‘/packages/downloaded_rpms/perl-threads-1.87-4.el7.x86_64.rpm’ -> ‘/yum_local/perl-threads-1.87-4.el7.x86_64.rpm’
‘/packages/downloaded_rpms/perl-threads-shared-1.43-6.el7.x86_64.rpm’ -> ‘/yum_local/perl-threads-shared-1.43-6.el7.x86_64.rpm’
‘/packages/downloaded_rpms/perl-Time-HiRes-1.9725-3.el7.x86_64.rpm’ -> ‘/yum_local/perl-Time-HiRes-1.9725-3.el7.x86_64.rpm’
‘/packages/downloaded_rpms/perl-Time-Local-1.2300-2.el7.noarch.rpm’ -> ‘/yum_local/perl-Time-Local-1.2300-2.el7.noarch.rpm’
‘/packages/downloaded_rpms/pytalloc-2.1.14-1.el7.x86_64.rpm’ -> ‘/yum_local/pytalloc-2.1.14-1.el7.x86_64.rpm’
‘/packages/downloaded_rpms/repodata’ -> ‘/yum_local/repodata’
‘/packages/downloaded_rpms/repodata/8ee366a158d2216b2e4091aec4d6bc9ee6e1fb6151d255239c18ba81acfedab3-filelists.sqlite.bz2’ -> ‘/yum_local/repodata/8ee366a158d2216b2e4091aec4d6bc9ee6e1fb6151d255239c18ba81acfedab3-filelists.sqlite.bz2’
‘/packages/downloaded_rpms/repodata/7c7384ff414588716f8c32e639ab89f803dbbab1025844803f5b26afe9740186-other.xml.gz’ -> ‘/yum_local/repodata/7c7384ff414588716f8c32e639ab89f803dbbab1025844803f5b26afe9740186-other.xml.gz’
‘/packages/downloaded_rpms/repodata/dd9980411f07a0c1ea672e5e749a867b932b024380ac4e9d5884dc826a315e0a-filelists.xml.gz’ -> ‘/yum_local/repodata/dd9980411f07a0c1ea672e5e749a867b932b024380ac4e9d5884dc826a315e0a-filelists.xml.gz’
‘/packages/downloaded_rpms/repodata/404ed886d6c58d8a2652601297495bc313fb283e7e5bf9ad6e00875f7106ef55-other.sqlite.bz2’ -> ‘/yum_local/repodata/404ed886d6c58d8a2652601297495bc313fb283e7e5bf9ad6e00875f7106ef55-other.sqlite.bz2’
‘/packages/downloaded_rpms/repodata/0c41f60b011a52ccf4c5859607dd66406a9bc397ab41c9fc792ab5f97a734e17-primary.xml.gz’ -> ‘/yum_local/repodata/0c41f60b011a52ccf4c5859607dd66406a9bc397ab41c9fc792ab5f97a734e17-primary.xml.gz’
‘/packages/downloaded_rpms/repodata/repomd.xml’ -> ‘/yum_local/repodata/repomd.xml’
‘/packages/downloaded_rpms/repodata/12082cbe209418daf3493968de0a45458a9aca90415aefff70cf27da7545ccef-primary.sqlite.bz2’ -> ‘/yum_local/repodata/12082cbe209418daf3493968de0a45458a9aca90415aefff70cf27da7545ccef-primary.sqlite.bz2’
‘/packages/downloaded_rpms/samba-4.9.1-10.el7_7.x86_64.rpm’ -> ‘/yum_local/samba-4.9.1-10.el7_7.x86_64.rpm’
‘/packages/downloaded_rpms/samba-client-libs-4.9.1-10.el7_7.x86_64.rpm’ -> ‘/yum_local/samba-client-libs-4.9.1-10.el7_7.x86_64.rpm’
‘/packages/downloaded_rpms/samba-common-4.9.1-10.el7_7.noarch.rpm’ -> ‘/yum_local/samba-common-4.9.1-10.el7_7.noarch.rpm’
‘/packages/downloaded_rpms/samba-common-libs-4.9.1-10.el7_7.x86_64.rpm’ -> ‘/yum_local/samba-common-libs-4.9.1-10.el7_7.x86_64.rpm’
‘/packages/downloaded_rpms/samba-common-tools-4.9.1-10.el7_7.x86_64.rpm’ -> ‘/yum_local/samba-common-tools-4.9.1-10.el7_7.x86_64.rpm’
‘/packages/downloaded_rpms/samba-libs-4.9.1-10.el7_7.x86_64.rpm’ -> ‘/yum_local/samba-libs-4.9.1-10.el7_7.x86_64.rpm’
‘/packages/downloaded_rpms/vim-common-7.4.629-6.el7.x86_64.rpm’ -> ‘/yum_local/vim-common-7.4.629-6.el7.x86_64.rpm’
‘/packages/downloaded_rpms/vim-enhanced-7.4.629-6.el7.x86_64.rpm’ -> ‘/yum_local/vim-enhanced-7.4.629-6.el7.x86_64.rpm’
‘/packages/downloaded_rpms/vim-filesystem-7.4.629-6.el7.x86_64.rpm’ -> ‘/yum_local/vim-filesystem-7.4.629-6.el7.x86_64.rpm’
‘/packages/downloaded_rpms/wget-1.14-18.el7_6.1.x86_64.rpm’ -> ‘/yum_local/wget-1.14-18.el7_6.1.x86_64.rpm’
‘/packages/downloaded_rpms/which-2.20-7.el7.x86_64.rpm’ -> ‘/yum_local/which-2.20-7.el7.x86_64.rpm’
[root@stbkp01 /]# cd /etc/
[root@stbkp01 etc]# createrepo /yum_local/
Spawning worker 0 with 28 pkgs
Spawning worker 1 with 27 pkgs
Workers Finished
Saving Primary metadata
Saving file lists metadata
Saving other metadata
Generating sqlite DBs
Sqlite DBs complete
[root@stbkp01 etc]# yum clean all
Loaded plugins: fastestmirror, ovl
Cleaning repos: centos7
Cleaning up list of fastest mirrors
Other repos take up 73 M of disk space (use --verbose for details)
[root@stbkp01 etc]# yum repolist all
Loaded plugins: fastestmirror, ovl
Determining fastest mirrors
centos7                                                                                | 2.9 kB  00:00:00
centos7/primary_db                                                                     |  57 kB  00:00:00
repo id                                          repo name                                         status
centos7                                          centos7                                           enabled: 55
repolist: 55
[root@stbkp01 etc]# ls
adjtime                  exports      krb5.conf.d        pam.d           rc.local        subuid
adjtime.rpmsave          filesystems  ld.so.cache        passwd          redhat-release  sudo.conf
aliases                  gcrypt       ld.so.conf         passwd-         resolv.conf     sudoers
alternatives             gnupg        ld.so.conf.d       pkcs11          rpc             sudoers.d
bash_completion.d        GREP_COLORS  libaudit.conf      pki             rpm             sudo-ldap.conf
bashrc                   group        libuser.conf       pm              rsyslog.d       sysconfig
binfmt.d                 group-       locale.conf        popt.d          rwtab           sysctl.conf
BUILDTIME                gshadow      localtime          ppp             rwtab.d         sysctl.d
centos-release           gshadow-     login.defs         prelink.conf.d  sasl2           systemd
centos-release-upstream  gss          logrotate.d        printcap        securetty       system-release
chkconfig.d              host.conf    machine-id         profile         security        system-release-cpe
csh.cshrc                hostname     modprobe.d         profile.d       selinux         terminfo
csh.login                hosts        modules-load.d     protocols       services        tmpfiles.d
dbus-1                   hosts.allow  motd               python          shadow          udev
default                  hosts.deny   mtab               rc0.d           shadow-         vconsole.conf
depmod.d                 init.d       NetworkManager     rc1.d           shells          virc
DIR_COLORS               inittab      networks           rc2.d           skel            X11
DIR_COLORS.256color      inputrc      nsswitch.conf      rc3.d           ssh             xdg
DIR_COLORS.lightbgcolor  iproute2     nsswitch.conf.bak  rc4.d           ssl             xinetd.d
dracut.conf              issue        openldap           rc5.d           statetab        yum
dracut.conf.d            issue.net    opt                rc6.d           statetab.d      yum.conf
environment              krb5.conf    os-release         rc.d            subgid          yum.repos.d
[root@stbkp01 etc]# vi yum.conf
[root@stbkp01 etc]# cd yum.repos.d/
[root@stbkp01 yum.repos.d]# ls
yum_local.repo
[root@stbkp01 yum.repos.d]# vi yum_local.repo
[root@stbkp01 yum.repos.d]# yum repolist all
Loaded plugins: fastestmirror, ovl
Loading mirror speeds from cached hostfile
repo id                                          repo name                                         status
centos7                                          centos7                                           enabled: 55
repolist: 55
[root@stbkp01 yum.repos.d]# yum install samba
Loaded plugins: fastestmirror, ovl
Loading mirror speeds from cached hostfile
centos7                                                                                | 2.9 kB  00:00:00
Resolving Dependencies
--> Running transaction check
---> Package samba.x86_64 0:4.9.1-10.el7_7 will be installed
--> Processing Dependency: samba-libs = 4.9.1-10.el7_7 for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: samba-common-tools = 4.9.1-10.el7_7 for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: samba-common-libs = 4.9.1-10.el7_7 for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: samba-common = 4.9.1-10.el7_7 for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: samba-common = 4.9.1-10.el7_7 for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: samba-client-libs = 4.9.1-10.el7_7 for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libwbclient = 4.9.1-10.el7_7 for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libxattr-tdb-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libutil-tdb-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libutil-reg-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libtevent.so.0(TEVENT_0.9.9)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libtevent.so.0(TEVENT_0.9.21)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libtevent.so.0(TEVENT_0.9.16)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libtevent-util.so.0(TEVENT_UTIL_0.0.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.5)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libtalloc.so.2(TALLOC_2.0.2)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsys-rw-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsocket-blocking-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsmbd-shim-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsmbd-base-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsmbconf.so.0(SMBCONF_0)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsmb-transport-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libserver-id-db-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsecrets3-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba3-util-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-util.so.0(SAMBA_UTIL_0.0.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-sockets-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-security-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-passdb.so.0(SAMBA_PASSDB_0.2.0)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-hostconfig.so.0(SAMBA_HOSTCONFIG_0.0.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-errors.so.1(SAMBA_ERRORS_1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-debug-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-cluster-support-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libreplace-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libpopt-samba3-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libndr.so.0(NDR_0.0.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libndr-standard.so.0(NDR_STANDARD_0.0.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libndr-samba-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libndr-nbt.so.0(NDR_NBT_0.0.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libmsghdr-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libmessages-dgm-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: liblibsmb-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libgse-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libgenrand-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libdbwrap-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libcmdline-contexts-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libcliauth-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libcli-smb-common-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libcli-nbt-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libcli-cldap-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libauth-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libCHARSET3-samba4.so(SAMBA_4.9.1)(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libxattr-tdb-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libutil-tdb-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libutil-reg-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libtevent.so.0()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libtevent-util.so.0()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libtdb.so.1()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libtalloc.so.2()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsys-rw-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsocket-blocking-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsmbd-shim-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsmbd-base-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsmbconf.so.0()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsmb-transport-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libserver-id-db-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsecrets3-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba3-util-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-util.so.0()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-sockets-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-security-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-passdb.so.0()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-hostconfig.so.0()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-errors.so.1()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-debug-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libsamba-cluster-support-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libreplace-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libpopt-samba3-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libndr.so.0()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libndr-standard.so.0()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libndr-samba-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libndr-nbt.so.0()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libmsghdr-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libmessages-dgm-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: liblibsmb-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libgse-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libgenrand-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libdbwrap-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libcmdline-contexts-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libcliauth-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libcli-smb-common-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libcli-nbt-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libcli-cldap-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libauth-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libCHARSET3-samba4.so()(64bit) for package: samba-4.9.1-10.el7_7.x86_64
--> Running transaction check
---> Package libtalloc.x86_64 0:2.1.14-1.el7 will be installed
---> Package libtdb.x86_64 0:1.3.16-1.el7 will be installed
---> Package libtevent.x86_64 0:0.9.37-1.el7 will be installed
---> Package libwbclient.x86_64 0:4.9.1-10.el7_7 will be installed
---> Package samba-client-libs.x86_64 0:4.9.1-10.el7_7 will be installed
--> Processing Dependency: libldb.so.1(LDB_1.3.0)(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libldb.so.1(LDB_1.1.30)(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libldb.so.1(LDB_1.1.19)(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libldb.so.1(LDB_1.1.1)(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libldb.so.1(LDB_0.9.23)(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libldb.so.1(LDB_0.9.15)(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libldb.so.1(LDB_0.9.10)(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libldb.so.1()(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libjansson.so.4()(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libcups.so.2()(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libavahi-common.so.3()(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libavahi-client.so.3()(64bit) for package: samba-client-libs-4.9.1-10.el7_7.x86_64
---> Package samba-common.noarch 0:4.9.1-10.el7_7 will be installed
---> Package samba-common-libs.x86_64 0:4.9.1-10.el7_7 will be installed
---> Package samba-common-tools.x86_64 0:4.9.1-10.el7_7 will be installed
---> Package samba-libs.x86_64 0:4.9.1-10.el7_7 will be installed
--> Processing Dependency: libpytalloc-util.so.2(PYTALLOC_UTIL_2.1.9)(64bit) for package: samba-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libpytalloc-util.so.2(PYTALLOC_UTIL_2.1.6)(64bit) for package: samba-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libpytalloc-util.so.2(PYTALLOC_UTIL_2.0.6)(64bit) for package: samba-libs-4.9.1-10.el7_7.x86_64
--> Processing Dependency: libpytalloc-util.so.2()(64bit) for package: samba-libs-4.9.1-10.el7_7.x86_64
--> Running transaction check
---> Package avahi-libs.x86_64 0:0.6.31-19.el7 will be installed
---> Package cups-libs.x86_64 1:1.6.3-40.el7 will be installed
---> Package jansson.x86_64 0:2.10-1.el7 will be installed
---> Package libldb.x86_64 0:1.4.2-1.el7 will be installed
---> Package pytalloc.x86_64 0:2.1.14-1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================
 Package                         Arch                Version                       Repository            Size
==============================================================================================================
Installing:
 samba                           x86_64              4.9.1-10.el7_7                centos7              685 k
Installing for dependencies:
 avahi-libs                      x86_64              0.6.31-19.el7                 centos7               61 k
 cups-libs                       x86_64              1:1.6.3-40.el7                centos7              358 k
 jansson                         x86_64              2.10-1.el7                    centos7               37 k
 libldb                          x86_64              1.4.2-1.el7                   centos7              144 k
 libtalloc                       x86_64              2.1.14-1.el7                  centos7               32 k
 libtdb                          x86_64              1.3.16-1.el7                  centos7               48 k
 libtevent                       x86_64              0.9.37-1.el7                  centos7               40 k
 libwbclient                     x86_64              4.9.1-10.el7_7                centos7              111 k
 pytalloc                        x86_64              2.1.14-1.el7                  centos7               17 k
 samba-client-libs               x86_64              4.9.1-10.el7_7                centos7              4.9 M
 samba-common                    noarch              4.9.1-10.el7_7                centos7              210 k
 samba-common-libs               x86_64              4.9.1-10.el7_7                centos7              171 k
 samba-common-tools              x86_64              4.9.1-10.el7_7                centos7              456 k
 samba-libs                      x86_64              4.9.1-10.el7_7                centos7              260 k

Transaction Summary
==============================================================================================================
Install  1 Package (+14 Dependent packages)

Total download size: 7.5 M
Installed size: 25 M
Is this ok [y/d/N]: y
Downloading packages:
--------------------------------------------------------------------------------------------------------------
Total                                                                         216 MB/s | 7.5 MB  00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : libtalloc-2.1.14-1.el7.x86_64                                                             1/15
  Installing : libtdb-1.3.16-1.el7.x86_64                                                                2/15
  Installing : libtevent-0.9.37-1.el7.x86_64                                                             3/15
  Installing : samba-common-4.9.1-10.el7_7.noarch                                                        4/15
  Installing : libldb-1.4.2-1.el7.x86_64                                                                 5/15
  Installing : avahi-libs-0.6.31-19.el7.x86_64                                                           6/15
  Installing : 1:cups-libs-1.6.3-40.el7.x86_64                                                           7/15
  Installing : pytalloc-2.1.14-1.el7.x86_64                                                              8/15
  Installing : jansson-2.10-1.el7.x86_64                                                                 9/15
  Installing : libwbclient-4.9.1-10.el7_7.x86_64                                                        10/15
  Installing : samba-common-libs-4.9.1-10.el7_7.x86_64                                                  11/15
  Installing : samba-client-libs-4.9.1-10.el7_7.x86_64                                                  12/15
  Installing : samba-libs-4.9.1-10.el7_7.x86_64                                                         13/15
  Installing : samba-common-tools-4.9.1-10.el7_7.x86_64                                                 14/15
  Installing : samba-4.9.1-10.el7_7.x86_64                                                              15/15
  Verifying  : samba-4.9.1-10.el7_7.x86_64                                                               1/15
  Verifying  : samba-client-libs-4.9.1-10.el7_7.x86_64                                                   2/15
  Verifying  : libtalloc-2.1.14-1.el7.x86_64                                                             3/15
  Verifying  : pytalloc-2.1.14-1.el7.x86_64                                                              4/15
  Verifying  : libtdb-1.3.16-1.el7.x86_64                                                                5/15
  Verifying  : 1:cups-libs-1.6.3-40.el7.x86_64                                                           6/15
  Verifying  : samba-libs-4.9.1-10.el7_7.x86_64                                                          7/15
  Verifying  : libwbclient-4.9.1-10.el7_7.x86_64                                                         8/15
  Verifying  : avahi-libs-0.6.31-19.el7.x86_64                                                           9/15
  Verifying  : libldb-1.4.2-1.el7.x86_64                                                                10/15
  Verifying  : samba-common-tools-4.9.1-10.el7_7.x86_64                                                 11/15
  Verifying  : libtevent-0.9.37-1.el7.x86_64                                                            12/15
  Verifying  : samba-common-4.9.1-10.el7_7.noarch                                                       13/15
  Verifying  : samba-common-libs-4.9.1-10.el7_7.x86_64                                                  14/15
  Verifying  : jansson-2.10-1.el7.x86_64                                                                15/15

Installed:
  samba.x86_64 0:4.9.1-10.el7_7

Dependency Installed:
  avahi-libs.x86_64 0:0.6.31-19.el7                      cups-libs.x86_64 1:1.6.3-40.el7
  jansson.x86_64 0:2.10-1.el7                            libldb.x86_64 0:1.4.2-1.el7
  libtalloc.x86_64 0:2.1.14-1.el7                        libtdb.x86_64 0:1.3.16-1.el7
  libtevent.x86_64 0:0.9.37-1.el7                        libwbclient.x86_64 0:4.9.1-10.el7_7
  pytalloc.x86_64 0:2.1.14-1.el7                         samba-client-libs.x86_64 0:4.9.1-10.el7_7
  samba-common.noarch 0:4.9.1-10.el7_7                   samba-common-libs.x86_64 0:4.9.1-10.el7_7
  samba-common-tools.x86_64 0:4.9.1-10.el7_7             samba-libs.x86_64 0:4.9.1-10.el7_7

Complete!
[root@stbkp01 yum.repos.d]# thor@jump_host /$

what did i do wrong

yum_local.repo file

[centos7]

Repository ID: yum_local

name=centos7

baseurl=file:///yum_local/

enabled=1

gpgcheck=0

Hi Inderpreet,

I faced the same issue, I was able to install httpd on the server, but task got failed.

Hi @Inderpreet,

Can you please look into my request?

@kodekloud-support3 can you please look into my request?

@labheshp there must be some custom name you have been given in question to use as the repo name and ID but seems like you just simply used centos7 which caused this to fail.

@mashraf92 same case for you, repo name and ID was supposed to be yum_local but you set it to yum-local which caused it to fail.

Hi,

I tried this exercise using the following steps

#cd /packages/downloaded_rpms/
#rm -rf ./repodata

createrepo .

cd /etc/yum.repos.d

vi localyum

[localyum]
Name=localyum
baseurl=file:///packages/downloaded_rpms/
enabled=1
gpgcheck=0

:wq

#yum clean all
I got an error message

Please will be glad if someone can tell me what I did wrong

I think name is incorrect should be yum_local not localyum.
you don’t need to do enabled = 1 instead of remove that section

[yum_local]
name=yum_local
baseurl=file:///packages/downloaded_rpms
gpgcheck=0

That was the name given in my task, thought the enabled section was also needed. Thanks for replying

@Ade seems like you missed to install the required package (whichever you were asked to install) after configuring the yum repo.