Configure Local Yum repos - failed

Hi Team,

i have completed task (Configure Local Yum repos) and please find commands, screenshots.but my task was failed with ‘samba’ package was not installed from ‘yum_local’ yum repository on Backup Server.

i am installed samba package with successfully and started service also…

cd /etc/yum.repos.d

vi yum_local

[yum_local]
name=yum_local
baseurl=file:///packages/downloaded_rpms
gpgcheck=0


image
image
image

please let me know the status of the task what i have done wrong in this task.

image

Hi @gunjiramanje, could you please share the task which was assigned?

image

@gunjiramanje Thanks for the picture you posted, I can see you added the following content in your yum_local.repo file:
[yum_local]
name=yum_local
baseurl=file:///packages/downloaded_rpms
gpgcheck=0

However you need to append one more line there:
enabled=1
Your final file should look like:
[yum_local]
name=yum_local
baseurl=file:///packages/downloaded_rpms
gpgcheck=0
enabled=1

enabled=1 , will mark this repository as a package source and then try installing samba.

1 Like

Hi ,
I have same issue, yum local repo configuration task failed even though I did it perfectly and installed wget. But error was “wget pkg not installed”.

[root@stbkp01 ~]# cat /etc/yum.repos.d/local_yum.repo
[local_repo]
name=local_yum
baseURL=file:///packages/downloaded_rpms/
enabled=1
gpgcheck=0
[root@stbkp01 ~]#

What is the command that you run to install wget after configuring the repository?
please share all the steps here

[root@stbkp01 ~]# cat /etc/yum.repos.d/local_yum.repo
[local_repo]
name=local_yum
baseURL=file:///packages/downloaded_rpms/
enabled=1
gpgcheck=0
[root@stbkp01 ~]#

yum clean all

yum repolist

yum install wget -y

1 Like

Install wget using below command
yum install --disablerepo="*" --enablerepo= “local_yum” wget

Do not install the package directly.

1 Like

Below steps worked to me.

cd /etc/yum.repos.d
vi localyum.repo

[localyum]
name=localyum
baseurl=file:///packages/downloaded_rpms/
enabled = 1
gpgcheck = 0

yum clean all
yum repolist
yum install --disablerepo="*" --enablerepo=“localyum” httpd