Apache Troubleshooting

Hi Team,

I checked the app2 8083 and cleared the configuration error and other two server worked on 8080 and finished the session . But it was failed , it was mentioned to check the service of apchache with curl i did it .please find the attachement

Hello Dinesh, by any chances have you check the port 8083 via netstat command was it listening ?

no i dint check other APP is configured with port 8080 .i checked the same with curl command and it was succusfull

Hi @dineshtobe

Since it is clearly mentioned in the question that all apps are using same Apache port i.e 8083 in your case I believe. So you need to make sure they all work on same port which is mentioned in the question and also curl should work for all apps at the end on the correct port.

thanks for the clarification

After multiple try I am able to finish this task successfully.

@Inderpreet KodeKloud team task is complex & time consuming but points assigned to the task was not appropriate.

Thanks,
Pradip

1 Like


Please i dont understand why i failed this task


everything seems ok but i still failed

You should resolve the error H00558 by adding IP address of the app server in ServerName section along with port in httpd.conf file.

Thanks,
Pradip

@nobleaxis Seems like you restarted Iptables service without saving the rule you added so that rule was washed out. Due to that Apache was not reachable from jump host at all which made it to fail.

After stop sendmail service which take the port on apache service, i found a way to flush iptables
“iptables -F” This command flushes i.e. clears the firewall rules that are setup inside the Linux system

@Inderpreet @player001…I did all the requred changes in conf file and httpd is running on all 3 app servers …also, changed the port for all the app servers as mentioned in the statement…After curl command, I am able to connect to only 1 and 2 app servers and not 3…Please suggest…

I will suggest you, first do curl in same app server then go for other servers to avoid casualties and issues.

@player001…I tried it multiple times got the success at end…

1 Like

Failed here too…

The port for me was like var {{LISTEN_PORT}} - the default in the config was 8080 and I didnt not touched it.

So why failed?

Sorry for this issue, this tasks is marked as Pending for you. Please try again now.

1 Like

can you give me exact steps for Apache Troubleshooting?

You can validate config file like below :

httpd -t -f /etc/httpd/conf/httpd.conf

To chekc logs like below
journalctl -xe

journalctl -xe | grep httpd

My Solution: Apache troubleshooting KodeKloud

I am still working on this lab with 15 mins remaining before environment automatically closed and marked my task as failed without even clicking finished button myself, kindly review for me please.