Apache Troubleshooting task

Hi,

Port 8088

I’ve fixed the problem with the 3 app servers. App2 and app3 worked after fixing the typo errors in /etc/httpd/conf/httpd.conf and starting services

Regarding app1 it took me a lot to realize that the port was 8080 instead of 8088, finally I’ve changed it in the /etc/httpd/conf/httpd.conf, once restarted apache I got access from thor to the 3 app servers like you can see in the image below (sorry I can only paste one image)

image
In the image you can see I have access to app3 (172.168.238.12) and app1 (172.168.238.10)

I don’t understand why the task appears as failed when I have succesfull curl access.

The only thing I’m guessing is that the /var/www/index/index.html was empty and I’ve created a template from scratch. The exercise said nothing about any particular message displayed.

Can you please take a look?

PD: I’ve used 4 terminals to do the exercise, the video is showing only one, so it’s not possible to see from there the whole procedure.
Here you have the task review:
https://kodekloud-engineer.com/#!/task_review?task_id=5f6ceccc12d7a62af5ec6be0

Thanks

Hi,

This is the screenshot of the app2 curl access

image

Hello, @jsc
I cannot see your review. Is it resolved?

Hi,

My review is this one https://kodekloud-engineer.com/#!/task_review?task_id=5f6ceccc12d7a62af5ec6be0

Seems to be has been solved as failed with the subject:

  • static website is not running on App Server 1

I will contact the admins to let them know.

Thanks.

Hello, @jsc
I think you don’t need to change the original content of the index.html. In the task question, I haven’t seen anything to modify index.html content. Might be task validation also relate with the original content. That’s why your task marked as failed.
Hope you got your doubt clear.

Hi @player001,

Thanks for your answer.

The index.html document was empty, the file was already in the 3 app severs but without content, that’s why I added a basic html code.

Thanks