Apache Troubleshooting Failed Test

I was able to resolve all Apache servers and do successful curl commands from jump server

1 Like

Even mine task also got failed after verifying every curl from bastion. Don’t know what went wrong :frowning:

@labheshp
Seems like on app server 1 you miss configured the Apache document root so the xfusioncorp index page was not loading, hence task was marked as failed.

Hi @rohit.tiwari

Seems like you miss configured Apache document root on all app servers so task failed for you.

I remember it was set to /var/www/html

MY Apache task marked as failed. with below notes

Task Status - Failed

static website is not running on App Server 1
static website is not running on App Server 3

I did the trouble stooting in stapp02 server and was able access web page from jump server

thor@jump_host /$ curl http://172.16.238.11:6200
Welcome to xFusionCorp Industries !

the stapp02

could you please explain this.
I believe there nothing mentioned about static websites in question

typo " trouble shooting"

Hi @vivek.karakandy

Thanks for reporting this, after reviewing your answer we found that you were able to make it work (basically the curl command) for App server 2. However for App server 1 and 3 although you were able to start Apache service but you were getting connection refused error in response of curl command for App server 1 and for App server 3 you didn’t try the curl command at all and possibly it wasn’t working for app 3 as well.

In the question it was asked to make sure Apache works fine hence the curl command for all app servers. I hope it helps you understand why this task failed for you.

Dear team,

My task failed but i was able to reach app servers correctly. Please see attached screenshot.

how to do this task
i started httpd server then i checking the status of the server it getting fail how to active it please help me

yes I missed that … to validate the things in Appserver1 and 3 .

if you go through “systemctl status httpd”. you can see the reason why this service not started .you will get the clue in which section you need to look in to configuration file

@Inderpreet and others…

i am able to start the httpd service on stapp01 but getting connection refused when i try to access the ip given.

how to fix this…please guide. Thanks in advance.


pls help me how to solve i dont know how to do pls give an idea

@yogendra

Also make sure Apache is using the correct port (which is mentioned in the question) on each app.

@hitesh2

If you closely look into the output you can see the error clearly which is causing the failure.

@Inderpreet and other Techgeeks…

I see the service httpd is started after running “service httpd start”. Then i tried checking port 8087 status by running “Telnet 172.16.238.10 8087” (got an error Telnet command not found).
Tried installing Telnet by “yum install telnet” but authentication failure for root.

Please refer this snip and guide me am i going in a right way or i need to switch to any other method.

Linux expertise help is much needed here for an infant like me. Your guidance will be much appreciated. Thanks.

hi @MeetSreeky…here are many Linux enthusiasts who are trying hard to fix this but was not able to. Could you please guide all of us the step by step procedure you followed.
I am stuck in middle of this task…your guidance will be really helpful.

Hi @yogendra

Switch to user root using sudo i.e sudo su - root . After that try to install telnet and investigate further.


pls help me how to find error in the screnshoot what the error it is how to reslove it give an idea